RED HAT LINUX AFECTADO POR VULNERABILIDAD CRÍTICA

Red Hat anuncio recientemente una vulnerabilidad severa en su cliente DHCP, CVE-2018-1111 podría ser explotada por actores maliciosos para ejecutar comandos arbitrarios con privilegios de administrador en sistemas específicos.

Un miembro del equipo de seguridad informática de Google, Felix Wilhelm, encontró una vulnerabilidad crítica de inyección remota de comandos en la implementación del cliente DHCP de Red Hat Linux, el problema también afecta a otras distribuciones, como Fedora.

redhat

Los hackers maliciosos podrían aprovechar la vulnerabilidad, CVE-2018-1111, para ejecutar comandos arbitrarios con privilegios de administrador en sistemas específicos.

“Red Hat tiene conocimiento de una vulnerabilidad de inyección de comandos que se encuentra en un script incluido en los paquetes de cliente DHCP en Red Hat Enterprise Linux 6 y 7.” dice el aviso de seguridad de Red Hat.

“Un servidor DHCP malicioso, o un actor malicioso en la red local capaz de suplantar las respuestas DHCP, puede usar esta vulnerabilidad para ejecutar comandos arbitrarios con privilegios de administrador en los sistemas usando NetworkManager que está configurado para obtener la configuración de red utilizando el protocolo DHCP”.

Profesionales en seguridad informática comentan, que la aplicación de cliente DHCP recibe los parámetros de configuración de red, incluida la dirección IP y los servidores DNS, del servidor DHCP (Dynamic Host Control Protocol).

redhat 1

La falla de inyección del comando CVE-2018-1111 recae en el script de integración de NetworkManager de los paquetes de cliente DHCP en Red Hat Enterprise Linux.

El investigador de seguridad informática Barkın Kılıç publicó un PoC para el CVE-2018-1111, en donde se puede ver como el atacante accede al shell como root.

redhat 2redhat 3

Felix Wilhelm no mostro un código de exploits PoC, pero dijo que este es tan corto que incluso puede caber en un tweet.

El experto en seguridad comento que, un hacker que use un servidor DHCP malicioso o esté conectado a la misma red que la víctima, puede utilizar esta vulnerabilidad falsificando las respuestas DHCP, lo que le permite ejecutar comandos arbitrarios con privilegios de administrador en el sistema de la víctima que ejecuta el cliente DHCP vulnerable.

Como se menciono en el aviso de seguridad, la vulnerabilidad afecta a Red Hat Enterprise Linux 6 y 7. Se recomienda a los administradores actualizar sus paquetes a las versiones más nuevas tan pronto como sea posible.

Red Hat dijo que, “Los usuarios también tienen la opción de eliminar o desactivar el script vulnerable, pero esto evitará que algunos parámetros de configuración proporcionados por el servidor DHCP se configuren en un sistema local, como las direcciones de los servidores NTP o NIS locales”.

El experto en seguridad informática dijo que algunas distribuciones de Linux como OpenSUSE y Ubuntu no se ven afectadas por la vulnerabilidad porque su implementación de cliente DHCP no incluye el script de integración de NetworkManager de forma predeterminada. El experto nos deja la lista completa de las versiones afectadas de RHEL:

Advanced Update Support 6.4; Extended Update Support 7.3; Advanced Update Support 6.6; Red Hat Enterprise Linux 6; Extended Update Support 6.7; Advanced Update Support 7.2; Servidor TUS (v.6.6); RHEL 7; Extended Update Support 7.4; Virtualization 4 Management Agent para RHEL 7 Hosts; Advanced Update Support 6.5; y el Servidor Linux TUS (v. 7.2).

Otros de los servicios afectados son la actualización de Red Hat para SAP Solutions en las arquitecturas x86 e IBM Power. Fedora ya lanzo nuevas versiones de paquetes DHCP que contienen rectificaciones para Fedora 26, 27 y 28.t

Deja un comentario

This site uses Akismet to reduce spam. Learn how your comment data is processed.